• Problem install ExtLib with Eclipse Update Site

    By Günter Krembsler 8 years ago

    I try to install “ExtensionLibraryOpenNTF-901v00_11.20141217-1000” from extracted “updateSiteOpenNTF-designer” into “Eclipse UpdateSite (StdEclipseUpdateSite) version 9.0 (05.11.2012)” database on the server.

    I get “Notes error in 'Eclipse Update Site':

    LS2J Error. Java constructor failed to execute. (#304) in:
    Is2jclassjarreader. cjarreader.:new (line 18)< Isclasssitefeature: csitefeature::process (line 319) Isclasssitefeature: csitefeature::new (line 281) Isclasssitefeaturefadory: csitefeaturefactoryxfactornewfeature (line 33) Isclassimportfeature: cimportfeature::importfeatures (line 194) Isclassimportfeature: cimportfeature::process (line 47) Isclassimportui: cimportui::importfeatures (line 211) dlgimportsite: queryclose (line 15)
    Additional Info:

    (D:\ExtensionLibraryOpenNTF-901v00_11.20141217-11300\updateSiteOpe nNTF\features\org.openntf.extlib.domino.das.feature 9.0.1.v00_11 2014 1217-1000jar)

    Importing on local designer works fine. Also - before - i could succesfully import “Apache POI” from Openntf into updatesite.

    Any idea?

    Thanks for any support.


    • By Padraic Edwards 8 years ago

      The XPages team are investigating this problem. We will have more
      information next week and an SPR to track the issue is on its way.


      • By lisa henry 8 years ago

        The following SPR has been logged to track the issue; SPR# DTON9TCJWF: Notes 9.0.1FP3 Update Site does not work.
        This seems to be a general issue with update sites in 9.0.1 FP3.
        We will look to resolve the issue as soon as we can.


        • By Per Henrik Lausten 7 years ago

          I can confirm that 9.0.1 FP3 IF1 fixes this.

          • By Fernando Rodriguez 7 years ago

            I installed 9.0.1 FP3 IF1 in Server & Client, but the error continues….

          • By Max Martin 7 years ago


            I have “Release 9.0.1FP3 SHF109” German Version and the error is still there.
            I also switch to english in the regional settings… nothing changed error still there.

          • By Don Mottolo 7 years ago

            I got the same error with 9.0.1 FP3 IF1.

            As a work-around, I re-ran the Notes client FP3 installer to uninstall the fix packs, and did the import to the update site without a problem.

    • By miguel calvo 7 years ago

      SOLVED. You need to install JVMPatch_SR16FP3_W32_901.3_ClientServer as indicated in technote http://www-01.ibm.com/support/docview.wss?uid=swg21698222
      Once the JVM is updated the import process runs fine again.